The element can't be added here error

Bo.jangles posted this 14 October 2011


I've just downloaded the trial version.

A few issues so far are:
1. When trying to insert a Field (or any other element) in the existing document I get "The elemt can't be added here". No further help is available. This is anywhere within the document.
2. Forum site doesn't work very well on IE9. I couldn't type the text in the message body, buttons are pale and almost non visible.
3. Deployment topic is missing from the help file. (On the web site / Documentation when I click Deployment topic another index opens but no actual topic is displayed).


1 Posts
0 Points
Order By: Standard | Newest | Votes
jles posted this 16 October 2011


We are sorry, but our documentation has not been finished yet and mostly describes previous version of the toolkit (1.0). Currently we are focused to complete the documentation and to make some tutorial videos. The error you’ve got is weird because it never occurred before (the product has been used in several projects). It’s even stranger that it occurs anywhere on the document. The error is actually raised by MS Word. It usually happens when MS Word does not permit a content control to be inserted for some reason (Docentric Elements are actually content controls).

Can you please do the following:
- Try to insert a Rich Text content control from the Developer Tab in MS Word and see if you get the same error?
- Do you have Desing Mode turned on (Docentric Tab) while inserting an element? - Which version of MS Word are you using?
- Can you send us your problematic template? (you can do this via forum or
- Try to open the attached report template.

How to incorporate the Docentric report engine into your .NET application:
In your .NET application reference two DLLs through Add Reference/.NET: Docentric.Word.dll and DocumentFormat.OpenXml.dll.
After that, you should be able to use DocumentGenerator class to create your report based on your template and data source(s). Just check the examples in the documentation on how to use the DocumentGenerator class in order to generate reports.

Thank you for the feedback about the forum on IE9, we will check this issue.
-- Jure

154 Posts
294 Points
jles posted this 18 October 2011


are you saying that you couldn't place Docentric elements onto an ordinary .docx document? We have always been using the .docx documents for templates and this is the correct document type. And I must admit we never even tried to save templates as .docm documents. The .docm format is still an OpenXml format so I expect them to be processed by the Docentric report engine normally.

I could only reproduce the error after the document was saved as .doc, but the old format isn't supported by Docentric anyway. I surfed the web and could not find any issue on "disabled content controls".

Bojan, may I ask you to check if you can insert content controls on the .docx document manually from the developer tab in ribbon. By default it's not visible but you can show it:

-- Jure

154 Posts
294 Points
jles posted this 20 October 2011


I think we solved the issue. Recently, we have done quite a lot of testing in order to catch the issue. Today we finally managed to reproduce the behavior you ran into. To make the story short, we found out that every time the program was started (WORD 2010) or we created a new document, WORD created it as an old .doc document (Compatibility Mode) and we were unable to add Docentric elements. So, after saving the document into one of OOXML formats (.docx, .docm, ...) the problem disappeared.

Explanation: The Docentric elements are just ordinary content controls which are not supported by the .doc format. And this is the reason WORD won't let you add Docentric elements when in compatibility mode.

After searching the WORD 2010 options we found the option:
File -> Options -> Save -> Save files in this format
which was set to "Word 97-2003 Document (*.doc)".

I suspect that you might also have the same value as we had (".doc") for the setting. if this is the case you probably have to options:
- either change the setting to ".docx" (see the attached picture), or
- save each new document as .docx before you start editing it.

Please let us know if this solves your problem.


enter image description here

154 Posts
294 Points

Our 225449 members have posted 342 times in 101 discussions